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Barcode Scanner Not Functioning

The barcode scanner doesn’t pair, scan barcodes, or trigger actions.

Possible Causes

  1. The barcode scanner is not charged or powered on.
  2. The USB dongle is not connected or paired with the scanner.
  3. The barcode or QR code is unreadable.

 

Important: If your barcode scanner is connected via its USB power cable then make sure the usb is not connected to your ultrasound machine. If the usb for the scanner is plugged up to the ultrasound machine then using the scanner will cause the commands to go to your machine and NOT Momitalk. It should be plugged up via the usb port on your power strip or disconnected completely as the scanner is wireless and doesn't need to be plugged into the cable directly (Its mainly there to recharge the battery)

Solutions

  1. Power On and Charge the Scanner:

    • Ensure the barcode scanner is has a charge (this is indicated by the number of green bars currently lit on the top of the scanner.
    IMG_1684Screenshot 2025-03-20 152720
     
    • Press the scanner’s button to power it on (a blue light should appear).

    IMG_1685 Screenshot 2025-03-20 152742
    • If the blue light does not appear then there is a connection issue with the scanner, see next steps below.

  2. Check USB Dongle Pairing:

    • Confirm the dongle is securely inserted into the Mini PC’s USB port.
    • Re-pair the scanner by restarting both the Mini PC and taking out the usb dongle (labeled "Dongle) and pushing it back in.
    photo-output (12)

  3. Test with a Different Barcode:

    • Scan a clean test barcode to rule out print quality issues.
    • Ensure the scanner is held steady and at an appropriate distance.
  4. Connect the barcode scanner directly to the Mini PC:
    • Use the provided power cable for the barcode scanner (most likely currently plugged into your black cable box near the floor) and plug it into the slot where the dongle was originally placed (pull the dongle out and place it in the slot underneath of the barcode scanner for safe keeping)

    photo-output (14)

When to Contact Support

If pairing issues persist, contact the Help Desk at us_help@momitalk.com